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What is SailTool? 
 
SailTool is a program which allows the analysis of yacht sail images.   
 
The program permits the user to perform a range of measurements on the sails and rig of a yacht from images which 
have been loaded into the program. 
 
SailTool has been developed as a tool to help in the various stages of sailing, fine tuning, characterising and 
performance validation of yachts. 
 
SailTool provides the following analysis features: 

Draft Stripe parameterisation 
Stripe Depth measurement (from off the boat) 
Mast Bend measurement 
Spinnaker Head Angle measurement (and general angle measurement) 
Leech Twist Measurement 
The overlay of a customisable grid 
A Tape Measure Tool 
Spinnaker Flying Distance estimation 
Compare Analysis Results 

 
SailTool was developed by the Centre for Marine Science and Technology at Curtin University of Technology and is 
©2000 Curtin University. 
 
More information: 
 Getting Started 
 Sail Analysis Tools 
 
 
 
Getting Started 
 
Before starting SailTool it is necessary to load some yacht image files onto the computer you will be running SailTool.  
The possible ways of loading image files into the computer are:  

(a) download the images from a digital camera or  
(b) use a flat bed scanner to scan photographic prints.  Images can be in the following file formats: BMP, GIF, JPEG 

or PNG. 
 
The SailTool program is launched by selecting the SailTool program icon   from the START menu. 
 
Once the program window of the SailTool application is displayed, the next step is to load a yacht image file which is to 
be processed.  From the “FILE” menu select “OPEN...” and then select an image file to open.  (more information...) 
 
The loaded image should now be displayed on the SailTool main screen.  At this point you could either: 

(a) start using the Sail Imaging Analysis Tools (mast bend, stripe analysis, etc) or  
(b) setup the Configuration Information for the yacht depicted in this image (e.g. class type, mast length for this 

class, etc). 
 
Once you have finished performing the desired analyses on the image you can save the analysis information for this 
image (for access at a later time).  From the FILE menu choose the SAVE command - this will save a “*.saf” file 
containing the analysis information.  The sail image can then be closed or the SailTool application exited. 
 
This briefly explains the overall function of the SailTool program.  You are now welcome to find out more about the 
specific sail analysis features provided within the program. 
 



Yacht Classes and Class Data 
 
The SailTool program provides the capability to register the type of class of yacht depicted in a particular image and 
also memorise a range of data for that type of class.  This information can then be used to automate the Tape Measure 
Tool by avoiding the need for repeated re-entry of commonly used data - such as the mast height for a 49er. 
 
For example: 
The yacht could be one of a range of different yacht classes: 470, 49er, Europe, Finn, IMOC Mistral, etc.  Each yacht 
class has values for types of class data: boom length, mast height, transom width, etc. 
 
The user has the ability to add new yacht classes (by editing the “.ini” file) and define values for Class Data items which 
have not already been entered. 
 
To select the class of yacht  
 
The class of a particular yacht depicted in the current image can be selected as follows: 
1. From the Edit menu, choose “Select Class”.  (The Yacht Class Selection dialog box (shown below) is then 

displayed.) 
2. From the Class box, select the type of class.  (The current class data for that yacht classes is then displayed for 

reference purposes.) 
3. Choose the OK button. 
 

 

 
  
To edit the yacht class data  
 
The class data for particular yacht classes can be edited as follows: 
1. From the Edit menu, choose Edit Class Data.  The “Edit Yacht Class Data” dialog box (shown below) is displayed. 
2. From the Class box, click on the down arrow and select the type of class from the pull-down list. 
3. From the Item box, click on the down arrow and select the class data item to be edited from the pull-down list. 
4. In the Value box, enter a numerical value (the unit of measurement would normally be metres). 
5. Press the OK button. 
 

 
 
To add new yacht classes 
 
A new yacht class can be created in a similar process to above: 
1. From the Edit menu, choose Edit Class Data.  The “Edit Yacht Class Data” dialog box is displayed. 
2. Double click on the text in the Class box and type in the new Yacht Class name. 
3. From the Item box, click on the down arrow and select a class data item from the pull-down list. 



4. In the Value box, enter a numerical value (the unit of measurement would normally be metres). 
5. Press the OK button. 
6. Repeat this “edit yacht class data” process above to initialise the class data items for this new yacht class. 
 
To add new yacht class parameters 
 
A new yacht class parameter is added as follows: 
1. From the Edit menu, choose Add Class Parameter.  The “Add Yacht Class Parameter” dialog box is displayed. 
2. Type the name of the parameter you wish to add. 
3. Press the Add Parameter button and follow the prompts. 
4. The value of this parameter in each of the yacht classes will be set to 0.00 so you will now need to manually set 

those values which you wish to have meaningful values (using Edit→EditClassData from the main menu). 
 
To delete a yacht class parameter 
 
A yacht class parameter is deleted as follows: 
1. From the Edit menu, choose Delete Class Parameter.  The “Delete Yacht Class Parameter” dialog box is 

displayed. 
2. Select the name of the parameter you wish to delete from the drop-down list. 
3. Press the Delete Parameter button and follow the prompts. 
 



The User Interface 
 
The SailTool application provides a Windows style user interface which we hope you will find fairly intuitive to use.  
All of the program’s functions can be accessed from the pull down menus on the menu bar at the top left of the screen.  
Most of the main functions can also be accessed from the toolbar buttons.  While the program is being used, keep an 
eye on the status bar on the bottom of the screen - messages identifying which mode the program is in appear in this 
area.   
 

 
 
The SailTool program displays yacht images in their own window within the main SailTool application window.  
Multiple images can be loaded at once and individual windows can be maximised, minimised or closed in the normal 
Windows fashion.  You will probably find the program easiest to use if you maximise all windows to use the full screen 
area available.   
 
Each sail image window contains two Frames - the right hand frame contains the yacht sail image and the left hand 
frame is a text display of sail analysis results.  The relative size of the two frames can be adjusted by grabbing the 
dividing bar between the two frames.   
 
If you have multiple yacht images loaded into SailTool during the one session, you can gain easy access to all loaded 
images by using the commands in the WINDOW Menu. 
 
The SailTool application displays the results of most analysis tools as graphics overlaid on top of the sail image.  The 
overlaid graphics provide immediate feedback to the user that the program is functioning correctly.  (more 
information...) 
 
The SailTool application provides a range of shortcuts to speed up the activation of commonly performed tasks.  Three 
types of shortcuts provided by SailTool:  
 toolbar buttons, 
 keyboard shortcuts, and  
 right-clicking the mouse. 
 
Further information: 
 The menu bar 
 The toolbar 
 The status bar 
 Overlaid Graphics 
 shortcuts 
 



The Menu Bar 
 
The menu bar is the first point from which all of the analysis tools can be activated. 
 

 
 
Each item in the menu bar has its own associated pull-down menu: 
 

 
 
The FILE menu provides access to the standard file handling actions and access to recent documents.  The program is 
exited via the EXIT item in the FILE menu. 
 

 
 
The EDIT menu provides options for setting the yacht’s class and editing class data items as well as providing General 
Information for the loaded image and selecting the font for the text frame.  
 

 
 
The VIEW menu provides controls for the Zoom function and controls to toggle on and off the toolbar and status bar. 
 

 
 
The GRID menu provides access to the various functions of the GRID OVERLAY tool. 
 



 
 
The MAST menu provides access to the various functions of the MAST BEND ANALYSIS tool. 
 

 
 
The LEECH menu provides access to the various functions of the LEECH TWIST MEASUREMENT tool. 
 

 
 
The STRIPES menu provides access to the various functions of the DRAFT STRIPE ANALYSIS tool. 
 

 
 
The TOOLS menu provides access to four different tools: the TAPE MEASURE tool, the PROTRACTOR tool (for 
angle measurement), KITE FLYING DISTANCE tool and a tool to allow the COMPARISON OF ANALYSIS RESULTS.  
The option to change the colour of the overlaid graphics is also available. 
 

 
 
The WINDOW menu provides tools for accessing multiple image windows when the SailTool program has been 
loaded with 2 or more yacht images.  The Cascade, Tile Across Page and Tile Down Page items arrange the yacht 



image windows so that they can all be seen on the screen.  The bottom portion of the WINDOW menu lists the currently 
loaded yacht images.  Select the desired file name to go to that particular yacht image. 
 

 
 
The HELP menu provides access to this on-line help and access to the program’s about box. 
 
Further information: 
 File Handling 
 Yacht Classes and Class Data 
 Grid Overlay Tool 
 Mast Bend Analysis Tool 
 Leech Twist Measurement Tool 
 Draft Stripe Analysis Tool 
 Tape Measure Tool 
 Protractor Tool 
 Kite Flying Distance Tool 
 Compare Analysis Results 



The Toolbar 
 
The Toolbar buttons provide easy access to commonly used Sail Analysis functions.   
 

 
 
The meaning of each of the toolbar buttons can be easily determined by moving the cursor on top of the button and 
looking at the Status Bar. 
 
The meaning of each of the toolbar buttons shown above (from left to right) are as follows: 

•  Open File 
•  Save Results 

 

•  Set Tape Measure Reference Length 
•  Measure Length using Tape Measure tool 
•  Protractor Tool (for measuring angles) 
•  Kite Flying Distance 
•  Mast Bend Measurement tool 
•  Leech Twist Measurement tool 
•  Grid Overlay tool 
•  Draft Stripe Measurement tool 
 

•  Help (this document) 
•  About 

 
Sometimes individual toolbar buttons will be greyed out.  This occurs when the function activated by a particular button 
cannot be performed at this time: 
e.g.  

•  The Tape Measure tool cannot be used until a reference length has been set. 
•  The Flying Distance tool cannot be used until a reference length has been set. 
•  Sail Analysis Tools cannot be used when the results frame is selected. 

 
 
 
The Status Bar 
 
The Status Bar appears at the very bottom of the application window.  Information appears in this area identifying the 
particular mode the program is in.  Instructions for the correct order to select points also appear in this area   (e.g.  When 
the “Digitise Mast” tool is used, the message “Click on bottom and top of mast, then click on intermediate points.” 
appears in the status bar to remind the user of the correct sequence of operation.) 
 
Keep and eye on this area if you forget the sequence of events. 
 
 
 
Overlaid Graphics 
 
The SailTool application displays the results of most analysis functions as graphics overlaid on top of the sail image.  
An example of this is shown below: 
 

 
 
The overlaid graphics provide immediate feedback to the user that the program is functioning correctly.   
 



If the graphics are hard to see because the graphics are drawn using a similar colour to that appearing in the yacht 
image, it is possible for the user to change the colours used for the graphics.  Simply use the OPTIONS command in the 
relevant pull-down menu to change to graphics colours.   
 
For example: to change the colour of the Mast analysis graphics, select OPTIONS from the MAST menu. 
 
The overlaid graphics can be hidden or shown using the HIDE/SHOW command of each individual analysis tool. 
 
The program uses different types of graphic symbols to indicate different types of selection points:   

   This symbol indicates the primary end of a curve measurement (bottom of mast, clew of sail, etc) 
  This symbol indicates the secondary end of a curve measurement (top of mast, head of sail, etc). 
  This symbol indicates points entered by the user which the program uses to model the curve of the 

particular item you are digitising. 
 
Depending upon the tool graphics being displayed at any one time, the program may display a range of different curve 
or line graphics.  These can represent (a) the fitted curve (b) the straight line between start and end points (c) offset 
measurement locations and (d) parameter measurement locations (e.g. maximum camber, front and back %, etc). 
 
For more information see the help page for each of the analysis tools: 
 Mast Bend Measurement 
 Draft Stripe Measurement 
 Leech Twist Measurement 
 Angle Measurement 
 Grid Overlay 
 Tape Measure Tool 
 Flying Distance Estimation 
 



Results Frame 
 
The SailTool application displays various results information in the left hand frame of the sail image window.   
 
An example of the sail image window is shown below (reduced size).  Take note of the results frame on the left hand 
side and the yacht sail image on the right.  
 

 
 
The results frame shows (a) the general information registered for this image, (b) labeled image measurements and (c) 
analysis results.  The results frame allows the side-by-side comparison of results for two different sail images. 
 
The font size used in the results frame can be customised using the Select Font command from the Edit menu.  (Please 
note that the results frame must be selected to use the Select Font command - click in the results frame, then choose 
Select Font). 
 
The size of the results frame can be adjusted by dragging the dividing line between the two frames. 
 
More information: 
 General Information 
 Image Measurement Labels 
 
 
 
Zoom 
 
The SailTool application allows the user to zoom in and out of the image in the sail image window.  The image can be 
zoomed out so that the whole image can be seen at once (where the image is larger than the screen) or the image can be 
zoomed in so that fine detail in the image can be easily seen for digitisation.  The following zoom controls are 
accessible from the View menu: 
 

Zoom Function Function 
View → Zoom: Original Size Display the sail image at 1:1 size (1 image pixel to 1 display pixel) 
View → Zoom: In Enlarges the image in the display window by one step 
View → Zoom: Out Reduces the size of the image in the display window by one step 
View → Zoom: Fit to Window Resizes the sail image such that it fits the current display window (this could 

either mean and enlargement or a reduction depending upon the size of the 
window and the size of the image). 

 
Keyboard shortcuts also exist for the Zoom In and Zoom Out functions: 
 

Zoom Function Keyboard Shortcut 
View → Zoom: In PAGE UP 
View → Zoom: Out PAGE DOWN 

 
 
 



Shortcuts 
 
The SailTool application provides several shortcuts to speed up the use of the program.   
 
The toolbar buttons are the first type of shortcut.  These are discussed in the toolbar section. 
 
Keyboard shortcuts provide yet another way of activating the major functions of the program. 
 
General “Windows” type keyboard shortcuts: 
 

Key sequence       Function 
F1           HELP 
SHIFT F1     CONTEXT HELP 
 
CTRL N       NEW 
CTRL O       OPEN 
CTRL P       PRINT 
CTRL S       SAVE 
CTRL F4      CLOSE 
ALT  F4      EXIT 
 
CTRL C       COPY 
CTRL INSERT  COPY 
CTRL X       CUT 
SHIFT DEL    CUT 
CTRL V       PASTE 
SHIFT INSERT PASTE 
CTRL Z       UNDO 
ALT BACKSP   UNDO 

 
Specific “Sail Imaging” keyboard shortcuts: 
 

Key sequence       Function 
ESC          CANCEL THE CURRENT MODE (BACK TO ROOT) 
CTRL M       MAST DIGITISE 
CTRL G       GRID - DEFINE PRIMARY AXIS 
CTRL D       DRAFT STRIPE DIGITISE 
CTRL H       SHOW/HIDE TOGGLE THE CURRENT GRAPHICS 
CTRL A       ANGLE MEASUREMENT 
CTRL L       LEECH DIGITISE 
CTRL R       SET REFERENCE (for TAPE MEASURE) 
CTRL T       TAPE MEASURE 
CTRL F       MEASURE FLYING DISTANCE 
PAGE UP      ZOOM IN 
PAGE DOWN    ZOOM OUT 

 
During the Digitisation of the Mast, Stripes and Leech, a right click of the mouse will bring up the following option 
window: 
 

 
 
This pop-up allows quick access to the Analyse command as well as enabling the deletion of points and moving the 
start and end points.  Select the appropriate command to perform that action. 



General Information 
 
The SailTool program allows a range of general information to be defined for the image.   
 
Select General Information from the Edit menu and enter the relevant information in the General Information dialog 
box (shown below).  The information from the dialog box is saved in the “.saf” file when the Save Results command is 
used. 
 

  



File Handling 
 
The SailTool program’s file handling capabilities are similar to most Windows applications but with a few subtle 
differences. 
 
The most obvious file handling action of the program is the opening of image files.  The image file (either bmp, gif, jpg 
or png) holds the yacht image on which image analysis is to be performed.   
 
When the program’s image analysis tools are used, various analysis results are generated.  The program provides the 
capability of saving the analysis results so that they can be retrieved later without the need to re-analyse the image.  
When the File → Save Results command is selected, the program stores the sail analysis results in a separate file.  This 
file has the same file name as the image file but with the extension “.saf” (sail analysis file).  When you wish to load the 
image and access previously stored results, load the “.saf” file instead of the image file itself. 
 
Further information is available from the following topics: 
 File Types 
 Opening Files 
 Saving Results 
 Closing Files 
 
 
 
 
File Types 
 
There are three main types of files which the program deals with: 

•  Image Files 
•  Sail Analysis Files 
•  Initialisation File 
 

Image Files (*.bmp, *.gif, *.jpg, *.png) 
 
The program accepts image files in any of the following formats:   

BMP Windows Bitmap Format (*.bmp) 
GIF Compuserve Graphics Interchange Format (*.gif) 
JPEG Joint Pictures Expert Group Format (Lossy Compression) (*.jpg) 
PNG Portable Network Graphics Format (Lossless Compression) (*.png) 

 
Each format has its own characteristics and compromises between: file size, compression (lossy vs. lossless), colour 
depth and transportability.  If you have an image file in a format different from the above list, you could use a program 
such as Paint Shop Pro from JASC Inc. to convert the image to one of the above formats.  Paint Shop Pro is a shareware 
package available from: http://www.jasc.com 
 
Sail Analysis Files (*.saf) 
 
When the program’s image analysis tools are used, various analysis results are generated for the loaded image.  The 
program can save these analysis results so that they can be retrieved later without the need to re-analyse the image.  
When the FILE → SAVE command is used, the program stores the sail analysis results in a separate file.  This file has 
the same file name as the image file but with the extension “.saf” (sail analysis file).  When you wish to reload the 
analysis results and image, make sure you load the “.saf” file instead of the image file only. 
 
It is important to take some care when copying, moving or renaming image files so as to maintain the link with the sail 
analysis information (kept in the “*.saf” file).  When copying or moving image files, make sure you also copy or move 
the relevant “*.saf” file if you wish the analysis results to be retained.  If you rename the image file, make sure you also 
rename the relevant “*.saf” file so that it has the same file name as the image (but with the “.saf” extension of course). 
 
Please also be aware that some confusion could result if you had two image files with the same file name but different 
extension (e.g.  “whit1.jpg” and “whit1.png”).  Although the filename of the analysed file will be stored in the sail 
analysis file, it would be a good idea to avoid having different format image files with the same filename. 
 
Initialisation File (SailTool.ini) 
 



The SailTool application stores a range of configuration information in the “sailtool.ini” file located in the Windows 
directory.  This file stores the class list and class data, along with other configuration information.  If you enter 
additional classes and class data it would be to your advantage to backup this file in your regular backup routine.  The 
file is a text format file which can be edited with a text editor if so desired. 
 
 
 
Opening Files 
 

Files are opened using the OPEN command from the FILE menu or by pressing the FILE OPEN  toolbar button.  
This brings up the file open dialog box window from which you can select the file you wish to open.  At the bottom of 
the dialog box, the type of files to be displayed for easy selection can be selected from “All SailTool Files”, “Image 
Files”, “Sail Analysis Files” or “All Files”. 
 

 
 
If you wish to load an image with its previously saved sail analysis results, make sure you load the  relevant “*.saf” (sail 
analysis file). 
 
 
 
Saving Results 
 
The FILE SAVE RESULTS command saves the analysis data which has been measured from the currently displayed 
image file.  The SAVE RESULTS command does not save or modify the image file itself, it generates a sail analysis 
file for the loaded image (as discussed in the File Types help topic) with the same file name as the image file but with 
the extension “.saf”. 
 
Please read the precautions for copying, moving and renaming image files to ensure that an image file’s corresponding 
sail analysis file is not lost.  (see the File Types help topic). 
 
 
 
Closing Files 
 
The FILE CLOSE command closes the currently active (open) image window.   
 
If you wish to retain sail analysis information from the current image for use at a later time, use the File Save Results 
command to save a sail analysis file.  See the File Save help topic for more information. 
 
 
 



Exporting Data 
 
The File Export command exports/saves the sail analysis results in a text file.   
 
The data can then be used in external programs for further data analysis or databasing. 



Sail Analysis Tools 
 
The SailTool program can perform the following types of analysis on the yacht sails and the rig: 

•  Sail Draft Stripe Analysis (from ON the boat, looking up at sail, for the main, jib & spinnaker) using the Stripe 
Analysis Tool 

•  Sail Stripe Depth (from OFF the boat, from leech/luff coincident view of the sail) using the Tape Measure Tool 
•  Measurement of Mast Bend (side-ways or fore-aft) using the Mast Bend Analysis Tool 
•  Measurement of Spinnaker Leech to Luff Flying Distance and Stripe Depth (from luff/leech coincident 

view of spinnaker) using the Flying Distance Tool 
•  Measurement of Spinnaker Head Angle (from on boat) using the Protractor Tool 
•  Measurement of Leech Twist (from off the boat, from leech/luff coincident view of the sail) using the Leech 

Twist Measurement Tool 
 
The program also has the ability to: 

•  Superimpose a user-defined grid over the image using the Grid Overlay Tool 
•  Make arbitrary linear measurements within the image using the Tape Measure Tool 
•  Perform a side-by-side comparison of analysis curves using the Compare Analysis Results tool. 

 
More information: 
 Mast Bend Analysis Tool 
 Stripe Analysis Tool 
 Leech Twist Measurement Tool 
 Grid Overlay Tool 
 Tape Measure Tool 
 Protractor Tool 
 Spinnaker Flying Distance Tool 
 Compare Analysis Results Tool 



Mast Bend Measurement Tool 
 
The Mast Bend Measurement Tool allows the characterisation of the bend of the yacht’s mast.  Once the mast has been 
digitised by the user, the program calculates mast bend offsets as a percentage of the mast height.  Shown below is an 
example of the display after the mast has been digitised by the user. 
 

 
 
The process to perform a mast bend analysis is as follows: 

•  Select Digitise Mast from the Mast menu (or click the  toolbar button or press CTRL+M) 
•  Digitise the mast by selecting the bottom and top of the mast and then selecting points along the mast.  (more 

information...) 
•  Select Analyse from the Mast menu (or right-click the mouse and select Analyse). 
•  The “Mast Offsets” window will appear from which you can read the mast measurement values or adjust 

some of the configuration settings. (more information...) 
 
For further information, refer to the following topics: 
 Digitise Mast 
 Analyse Mast 
 Mast Graphics Options 
 Show/Hide the mast graphics 
 Definition of Mast Section Parameters 
 
 
 
Mast Digitise 
 
When the Digitise Mast mode is selected the user is prompted to “Click on bottom and top of mast, then click on 
intermediate points”.  Move the mouse around the screen to the bottom of the mast and then press the left mouse button.  
A   symbol will be shown at the point selected.  Next select the top of the mast - a   symbol will be displayed.  Next, 
select intermediate points along the mast - a   symbol will be displayed at every point selected.   
 
After you provide the first intermediate point, the program calculates and displays a fitted curve.  You can add further 
intermediate points so as to make the fitted curve fit the image on screen. 
 
At this stage the image could look something like this: 
 

 
 
If you wish to delete points, this is done by:  

(a) moving the mouse pointer over the point you wish to delete,  
(b) press the right mouse button, 
(c) the following window will appear: 
 



 
 
(d) select the “Delete Point” option. 

 
If you wish to move the mast base or mast tip points, this is done by:  

(a) move the mouse pointer to the place you wish the mast base or mast tip point to be,  
(b) press the right mouse button (the window shown above is displayed) and  
(c) select the “Move Mast Base” or “Move Mast Tip” option. 

 
Once you are happy with the digitised image (and the quality of the fitted curve), you are ready to analyse the results.  
Select Analyse from the Mast Menu (or right-click the mouse and select Analyse). 
 
During the digitisation process, a couple of special features of the program can be used to aid the digitisation process:  

•  You can zoom in and out of the image by pressing the PAGE UP and PAGE DOWN keys 
•  The overlaid graphics can be turned off and on by pressing CTRL+H. 
•  If the overlaid graphics are hard to see (probably because the graphics are the same colour as that appearing 

in the image), select OPTIONS from the MAST menu to change the colours used. 
 
Please note: 

•  The program can only be as accurate as the points which you select so please select the points carefully. 
•  When the “Mast Digitise” mode is selected, it is important that the bottom of the mast is the first point 

selected. 
 
 
 
Mast Analyse 
 
When the Mast Analyse mode is selected (either by selecting “Analyse” from the “Mast” menu or by right-clicking the 
mouse and selecting Analyse) the Mast Offset dialog box is displayed (shown below reduced size). 
 

 
 
Of primary interest is the listing of mast bend offsets and curve section parameters.  This information can be selected 
(using the mouse), copied (CTRL+INSERT) and pasted into another application. 
 
This window is very similar in function to the Analysis dialog box for the draft stripe and leech tools.  Please refer to 
the common Parameter Analysis Window help page for more detailed information on the functions of this window. 
 
Further information: 
 Parameter Analysis Window help page 
 



 
 
Mast Options 
 
The mast options window (shown below) is displayed when Options is chosen from the Mast menu.  This window 
allows the user to select the colours used for the overlaid graphics.  This could be used if one of the default colours 
clashed with the colours occurring in the yacht image. 
 

 

 
 
 
 
Mast Show/Hide 
 
The mast overlay graphics can be hidden or shown using the Hide Mast / Show Mast command in the Mast menu.  
This command can be used at any time.   
 
A short cut key CTRL+H can also be used but this only applies to the mast graphics when mast analysis is the current 
tool. 
 
 
 
Definition of Mast Parameters 
 
The section parameters calculated and shown in the parameter analysis dialog box are defined as follows: 
 

 

•  In the results list: Dist. refers to the distance from the base of the mast 
(up the straight line between base and tip) and Off. refers to the offset 
at that location.  0% is the base of the mast and 100% is the top of the 
mast. 

•  The CAMBER is the maximum offset of the mast. 
•  The DRAFT is the position along the straight line between mast base 

and tip of the maximum mast offset. 
•  FRONT% is the mast offset value half way between the camber and 

the mast base. 
•  BACK% is the mast offset value half way between the camber and 

the mast tip. 
•  Camber, draft, front%, back% and offsets are expressed as either: 
   (a) a percentage of the straight line distance between the mast base and 

tip, and/or 
   (b) a linear distance measurement. 
•  ENTRY angle is the angle (in degrees) between the straight line and 

the tangent of the curved line at the base of the mast. 
•  EXIT angle is the angle (in degrees) between the straight line and the 

tangent of the curved line at the tip of the mast. 
•  TWIST is the angle (in degrees) between the straight line and the 

bottom of the photograph. 
 

 
See also: 
 Parameter Analysis dialog box 
 Leech Parameter Definitions 
 Sail Stripe Parameter Definitions 



Sail Stripe Measurement Tool 
 
The Sail Stripe Measurement Tool allows the parameterisation of a sail’s draft or camber stripes.  This tool is only 
designed to be used on sail images taken from on the deck of the yacht.  Shown below is an example of the display after 
the sail’s draft stripes have been digitised with the draft stripe measurement tool. 
 

 
 
The process to perform a mast bend analysis is as follows: 

•  Select Digitise Sail Stripe from the Stripe menu (or click the  toolbar button, or press CTRL+D) 
•  Digitise the first (bottom) stripe by selecting the leading end (mast or luff end) of the stripe, then the select 

the trailing end (leech end) of the stripe, and then select points along the stripe.  (more information...) 

•  Digitise the next stripe by selecting Digitise Sail Stripe from the Stripe menu (or click the  toolbar 
button, or press CTRL+D), then digitise points on the stripe as per the previous step. 

•  Digitise all of the stripes by repeating the above process. 
•  Once you have digitised all stripes, select Analyse from the Stripe menu (or right-click the mouse and select 

Analyse). 
•  The Sail Stripes dialog box will appear from which you can read the sail stripe parameter values or adjust 

some of the configuration settings. (more information...) 
 
If you wish to have twist measurements calculated relative to the boom, it is necessary to digitise the boom.  This is 
done by selecting Define Boom from the Stripes Menu and then clicking on either end of the boom. 
 
For further information, refer to the following topics: 
 Digitise Sail Stripes 
 Analyse Sail Stripes 
 Sail Stripes Options 
 Show/Hide the sail stripe graphics 
 Define Boom 
 Show/Hide Boom 
 Definition of Sail Stripe Section Parameters 
 
 
 
 
 
Digitise Sail Stripes 
 
The digitisation of sail stripes is a multi-stage process - each sail stripe is digitised individually. 
 
When the Digitise Sail Stripes command is selected (from the Stripe menu), a dialog box (shown below) is displayed 
informing/asking the user which stripe is to be digitised.   Normally this will be the next undigitised stripe.  Confirm 
that it is the stripe you wish to digitise and press OK. 
 

 



 
The sail image will then be shown on the screen and the user is prompted to “Click on leading edge and trailing edge of 
stripe, then click on intermediate stripe points”.  Move the mouse pointer to the leading edge (mast or luff end) of the 
first (bottom) stripe and then press the left mouse button.  A   symbol will be shown at the point selected.  Next select 
the trailing edge (leech end) of the stripe - a   symbol will be displayed.  Next, select intermediate points along the 
stripe - a   symbol will be displayed at every point selected.   
 
After you provide the first intermediate point, the program calculates and displays a fitted curve.  You can add further 
intermediate points so as to make the fitted curve fit the image on screen. 
 
During the digitisation process you can delete points by:  

(a) move the mouse pointer over the point you wish to delete,  
(b) press the right mouse button (the following window will appear), and 
 

 
 
(d) select the “Delete Point” option. 

 
During the digitisation process you can change the position of the Leading Edge or Trailing Edge points by:  

(a) move the mouse pointer to the place you wish the Leading Edge or Trailing Edge point to be,  
(b) press the right mouse button (the window shown above is displayed), and 
(c) select the “Move Mast Base” or “Move Mast Tip” option. 

 
Once you are happy with the curve fit achieved with the first stripe you can proceed to digitise the remaining stripes.  
Select Digitise Sail Stripe from the Stripes menu.  Digitise the stripe using the process described above. 
 
Once you have digitised all of the stripes, the image could look something like this: 
 

 
 

If you are happy with the digitised image (and the quality of the fitted curves), you are ready to analyse the results.  
Select “Analyse” from the Stripes Menu (or right-click the mouse and select Analyse). 
 
During the digitisation process, several special features of the program can be used to aid the digitisation process:  

•  You can zoom in and out of the image by pressing the PAGE UP and PAGE DOWN keys 
•  The overlaid graphics can be turned off and on by pressing CTRL+H. 
•  If the overlaid graphics are hard to see (probably because the graphics are the same colour as the colours 

present in the image), select OPTIONS from the MAST menu to change the colours used. 
•  If you wish to edit or redigitise a previously digitised stripe, select Digitise Sail Stripe from the Stripes 

menu.  In the “Digitise Sail Stripes” dialog box which pops up, type in the number of the stripe you wish to 
edit or redigitise.  If you wish to redigitise the stripe, make sure “Clear existing points” is ticked and press 
OK.  If you wish to edit the digitised points, make sure “Clear existing points” is unticked and press OK. 

•  If you wish to calculate boom relative twist measurements, it is necessary to digitise the boom. 
 
Please note: 

•  The program can only be as accurate as the points which you select so please select the points carefully. 
•  It is important that the leading (luff) end of the stripe is the first point selected. 

 
 
 



Analyse Stripes 
 
When the Analyse Stripes command is selected (either by selecting “Analyse” from the “Stripes” menu or by right-
clicking the mouse and selecting Analyse) the Sail Stripes dialog box is displayed (shown below reduced size). 
 

 
 
Of primary interest is the listing of stripe curve offsets and stripe section parameters.  This information can be selected 
(using the mouse), copied (CTRL+INSERT) and pasted into another application. 
 
This window is very similar in function to the analysis window for mast and leech analysis.  Please refer to the common 
Parameter Analysis Dialog Box help page for more detailed information on the functions of this dialog box. 
 
Further information: 
 Parameter Analysis Dialog Box help page 
 
 
 
Sail Stripe Options 
 
The Sail Stripe Options dialog box (shown below) is displayed when Options is chosen from the Stripes menu.  This 
dialog box allows the user to select the colours used for the overlaid graphics.  This could be used if one of the default 
colours clashed with the colours occurring in the yacht image. 
 

 

 
 
This window also allows the user to set the number of draft stripes which appear on the sail.  The default number of 
stripes is 4.  It will only be necessary to change this figure if the sail image contains more or less than 4 sail stripes. 
 
 
 



Show/Hide Sail Stripes 
 
The sail stripe overlay graphics can be hidden or shown using the Hide Sail Stripes / Show Sail Stripes command in 
the Stripes menu.  This command can be used at any time.   
 
A short cut key CTRL+H can also be used but this only applies to the sail stripe graphics when sail stripe analysis is the 
current tool. 
 
 
 
Definition of Sail Stripe Parameters 
 
The section parameters calculated and shown in the parameter analysis dialog box are defined as follows: 
 

 
        leading edge                                                                       trailing edge 
 
•  In the results list: Dist. refers to the distance from the luff of the sail (along the straight line between luff and leech) 

and Off. refers to the offset at that location.   
•  The CAMBER is located at the point of maximum stripe depth. 
•  The DRAFT is the position along the straight line between leech and luff of the maximum offset. 
•  FRONT% is the offset value half way between the camber and the luff. 
•  BACK% is the offset value half way between the camber and the leech. 
•  Camber, draft, front%, back% and offsets are expressed as either: 
   (a) a percentage of the straight line distance between the luff and leech, and/or 
   (b) a linear distance measurement. 
•  ENTRY angle is the angle (in degrees) between the straight line and the tangent of the curved line at the luff. 
•  EXIT angle is the angle (in degrees) between the straight line and the tangent of the curved line at the leech. 
•  iTWIST is the angle (in degrees) between the (luff to leech) straight line and the bottom of the photograph. 
•  bTWIST is the angle (in degrees) between the (luff to leech) straight line and the boom (when the boom has been 

digitised). 
•  BOOM angle is the angle (in degrees) between the boom and the bottom of the photograph. 
 
See also: 
 Parameter Analysis dialog box 
 Mast Parameter Definitions 
 Leech Parameters Definitions 
 
 
 
 
Define Boom 
 
If you wish to calculate boom relative twist measurements during the sail stripe analysis process, it is necessary to 
digitise the boom. 
 
From the Stripes menu, select the Define Boom option.  Then click on both ends of the boom in the image. 
 
The boom overlay graphics can be hidden or shown using the Boom Show/Hide command. 
 
 
 



Show/Hide Boom 
 
The boom overlay graphics can be hidden or shown using the Hide Boom / Show Boom command in the Stripes menu.  
This command can be used at any time.   
 
A short cut key CTRL+H can also be used but this only applies to the boom graphics when boom digitisation is the 
current tool.



Leech Twist Measurement Tool 
 
The Leech Twist Measurement Tool allows the characterisation of the leech twist of a yacht’s sail.  This function only 
works optimally on images in which the leech of the sail is approximately coincident with the luff.  Once the sail’s 
leech has been digitised by the user, the program calculates leech twist offsets. 
 
The process to perform a leech twist analysis is as follows: 

•  Select “Digitise Leech Twist” from the Leech menu (or click the  toolbar button or press CTRL+L) 
•  Digitise the leech by selecting the clew and head of the sail and then selecting intermediate points along the 

leech.  (more information...) 
•  Select Analyse from the Leech menu (or right-click the mouse and select Analyse). 
•  The Sail Leech Offsets window will appear from which you can read the leech twist measurement values or 

adjust some of the configuration settings. (more information...) 
 
For further information, refer to the following topics: 
 Digitise Leech 
 Analyse Leech 
 Leech Graphics Options 
 Show/Hide the leech graphics 
 Definition of Leech Section Parameters 
 
 
 
Digitise Leech Twist 
 
When the Digitise Leech Twist command is selected, the sail image is displayed and the user is prompted to “Click on 
clew and head of sail, then click on intermediate leech points”.  Move the mouse to the clew of the sail and then press 
the left mouse button.  A   symbol will be shown at the point selected.  Next select the head of the sail - a   symbol 
will be displayed.  Next, select intermediate points along the leech - a   symbol will be displayed at every point 
selected.   
 
After you provide the first intermediate point, the program calculates and displays a fitted curve.  You can add further 
intermediate points so as to make the fitted curve fit the image on screen. 
 
At this stage the image could look something like this: 
 

 
 
If you wish to delete points, this is done by:  

(a) moving the mouse pointer over the point you wish to delete,  
(b) press the right mouse button, 
(c) the following window will appear: 
 

 
 
(d) select the “Delete Point” option. 



 
If you wish to move the sail clew or sail head points, this is done by:  

(a) move the mouse pointer to the place you wish the sail clew or sail head point to be,  
(b) press the right mouse button (the window shown above is displayed) and  
(c) select the “Move Clew” or “Move Head” option. 

 
Once you are happy with the digitised image (and the quality of the fitted curve), you are ready to analyse the results.  
Select “Analyse” from the Leech Menu (or right-click the mouse and select Analyse). 
 
During the digitisation process, several special features of the program can be used to aid the digitisation process:  

•  You can zoom in and out of the image by pressing the PAGE UP and PAGE DOWN keys 
•  The overlaid graphics can be turned off and on by pressing CTRL+H. 
•  If the overlaid graphics are hard to see (probably because the graphics are the same colour as that appearing 

in the image), select Options from the Leech menu to change the colours used. 
 
Please note: 

•  The program can only be as accurate as the points which you select so please select the points carefully. 
•  With this tool, it is important that the clew of the sail is the first point selected. 

 
 
Analyse Leech 
 
When the Analyse Leech mode is selected (either by selecting “Analyse” from the “Leech” menu or by right-clicking 
the mouse and selecting Analyse) the Sail Leech Offsets dialog box is displayed (shown below reduced size): 
 

 
 
Of primary interest is the listing of leech twist offsets and curve section parameters.  This information can be selected 
(using the mouse), copied (CTRL+INSERT) and pasted into another application. 
 
This window is very similar in function to the analysis window for mast and draft stripe analysis.  Please refer to the 
common Parameter Analysis Dialog Box help page for more detailed information on the functions of this dialog box. 
 
Further information: 
 Parameter Analysis Dialog Box help page 
 
 



Leech Options 
 

The leech options dialog box (shown below) is displayed when Options is chosen from the Leech menu.  This dialog 
box allows the user to select the colours used for the overlaid graphics.  This could be used if one of the default colours 
clashed with the colours occurring in the yacht image. 
 

 
 
 
Show/Hide Leech 
 
The mast overlay graphics can be hidden or shown using the Hide Leech / Show Leech command in the Leech menu.  
This command can be used at any time.   
 
A short cut key CTRL+H can also be used but this only applies to the mast graphics when the leech analysis is the 
current tool. 
 
 
Definition of Leech Parameters 
 
The section parameters calculated and shown in the parameter analysis dialog box are defined as follows: 
 

 

•  In the results list: Dist. refers to the distance from the clew of the sail 
(up the straight line between clew and head) and Off. refers to the 
offset at that location.  0% is the clew of the sail and 100% is the head 
of the sail. 

•  The CAMBER is the maximum offset. 
•  The DRAFT is the position along the straight line between clew and 

head of the maximum offset. 
•  FRONT% is the offset value half way between the camber and the 

sail clew. 
•  BACK% is the offset value half way between the camber and the sail 

head. 
•  Camber, draft, front%, back% and offsets are expressed as either: 
   (a) a percentage of the straight line distance between the sail clew and 

head, and/or 
   (b) a linear distance measurement. 
•  ENTRY angle is the angle (in degrees) between the straight line and 

the tangent of the curved line at the clew of the sail. 
•  EXIT angle is the angle (in degrees) between the straight line and the 

tangent of the curved line at the head of the sail. 
•  TWIST is the angle (in degrees) between the straight line and the 

vertical axis of the photograph. 
 

 
See also: 
 Parameter Analysis dialog box 
 Sail Stripe Parameter Definitions 
 Mast Parameter Definitions 



Parameter Analysis Dialog Box 
 
The parameter analysis dialog box (shown below reduced size) is displayed when the “Analyse” command is chosen 
from either the Mast, Stripe or Leech menus. 
 

 
 
The first item of interest in this window is the listing of analysis results.  The analysis results include: offsets (calculated 
from the clew/base/luff as either (a) a percentage of the section length or (b) a length in metres if a reference is given) 
and several other standard sectional parameters (Draft, Camber, Entry Angle, etc).  (See the Section Parameter 
Definitions page for the Mast, Leech and Sail Stripes for a full list and description of these parameters).   
 
The analysis results in this window can be selected (using the mouse) and copied (CTRL+INSERT) for use in another 
program (e.g. paste into notepad).   
 
On the lower half of the window the user is given the option to calculate (or non-dimensionalise) the offset values with 
respect to the straight end-to-end line length or the curved fitted line length and as either a percentage or a length in 
metres (see below for setting the reference length).  The user is also given the option to display parameters in metres 
based on a scale factor calculated when you tape measure reference an image (NB: be careful of perspective error).  
Select the appropriate radio button for the calculation method you wish to use. 
 
The user is also given the option of selecting how percentage parameters are displayed - either as a percentage of the 
camber size or as a percentage of the chord length.  Click the % of camber checkbox to select percentages to be 
displayed as a percentage of the camber. 
 
The user can also select the way in which the position of the offset measurement locations are calculated - either 
measured along the straight end-to-end line or along the curved fitted line.  Select the appropriate radio button for the 
calculation method you wish to use. 
 
Three buttons on the bottom of the screen allow you to: 

(a) Close (or dismiss) the window, 
(b) Access Help for this page, and 
(b) Access More analysis customisation options.  If the More button is pressed, the analysis window expands 

to reveal more functions.  (shown below reduced size) 
 



 
 
The “Curve fit parameters” area (top right) allows the user to select the technique used to calculate the curve fit.  In 
most cases a spline has been found to give very good results, however the user is given the option of using a polynomial 
(with user selectable order) to calculate the fit.  If the curve fit method is changed, press the “Re-calculate fit” button to 
immediately use the new method. 
 
The “Displayed image data” area (right centre) allows the user to select the type of overlaid graphics which are 
displayed on the sail image.  Click on the appropriate tick box to display or hide the following graphics items: (a) 
Digitised points (b) Curve fitted line (c) offset measurement locations and (d) section parameter locations (i.e. draft, 
front %, back %). 
 
The “Display stripes” area (right lower-centre) only appears when draft stripe analysis is being performed.  This area 
allows the user to select whether overlay graphics are displayed for all of the stripes or just a single stripe. 
 
The “Edit Ref. Length...” button brings up a window which allows you to enter the reference length (either straight line 
or along the curve) for when you want the offsets to be displayed in metres. 
 
The “Edit Offset Posn.” button brings up a windows which allows the offset measurement locations to be edited.  
When this button is pressed the following window is displayed: 
 

 
 
The user can change offset positions simply by double clicking the appropriate number and entering a new number via 
the keyboard. 
 
The user can add offset positions by double clicking on the add entry.   
 
The user can delete offset positions by selecting the entry you wish to delete and press the BACKSPACE key. 
 
At the bottom of the window, the “Number of Divisions” item allows the user to manually set the number of offset 
positions which exist.  When a number is entered into this box, the program recalculates all of the offset positions such 
that they are all evenly spaced between 0 and 100% 
 
Further information:  Exporting analysis data 



Protractor Tool (Angle Measurement) 
 
The Protractor Tool allows the measurement of angles in yacht sail images.  This function only works optimally when 
the plane of the angle measurement is perpendicular to the camera axis.  The tool provides a measure of angle in 
degrees.  Shown below is an example of the protractor tool being used to measure spinnaker head angle. 
 

  
 
The Protractor Tool is activated by selecting “Angle: Measure” from the Tools menu. 
 
Further information: 
 Angle: Measure 
 Angle: Display Previous 
 Tools Options 
 
 
 
 
Angle: Measure 
 
The process to measure an angle in an image is as follows: 

•  Select Angle: Measure from the Tools menu (or click the  toolbar button or press CTRL+A) 
•  Move the mouse to the first arm of the angle to be measured and press the left mouse button.   
•  Move the mouse to the apex of the angle to be measured and press the left button. 
•  Move the mouse to the second arm of the angle to be measured and press the left button. 
•  A dialog box (shown below) will then appear displaying the measured angle. 
 

   
 
•  If you wish to assign a label to this measurement (for later use) type a name for this measurement in the 

Label box.  (See the Measurement Labels help topic for more information.) 
•  Press Close to dismiss the dialog box. 
 

If you wish to redisplay the previously measured angle, select the “Angle: Display Previous” command from the Tools 
menu. 
 
Further information: 
 Angle: Display Previous 
 Tools Options 
 Measurement Labels 
 
 



Angle: Display Previous 
 
The Angle: Display Previous command from the Tools menu redisplays the previously measured angle.  The angle 
overlay graphics are redisplayed and the results dialog box is also redisplayed (as shown below reduced size). 

 

 
 

Press the Close button to dismiss the dialog box. 
 
Further information: 
 Angle: Measure 
 Tools Options 
 Measurement Labels 



Tools Options 
 
The Tools Options dialog box (shown below) is displayed when the Options command is chosen from the Tools menu.  
This dialog box allows the user to select the colours used for the overlaid graphics commands available from the Tools 
menu.  This could be used if one of the default colours clashed with the colours occurring in the yacht image. 
 

 
 



Grid Overlay Tool 
 
The Grid Overlay Tool allows the overlay of a user definable grid over the loaded yacht sail image.  The grid overlay 
tool provides a number of advanced features which allow the analysis of single images and the comparison of multiple 
images.  The image below shows an example of the grid overlay tool being used: 
 

  
 
The Grid Overlay Tool is activated as follows: 

•  Select “Define Primary Axis” from the Grid menu. 
•  Using the mouse, select two points which define the primary axis of the grid. 
•  The grid will then be displayed as shown in the image above. 

 
The grid can now be customised in a number of ways: 
 •  The grid can be moved using the Translate command. 
 •  The grid can be resized using the Resize command. 
 •  The grid can be rotated using the Rotate command. 
 •  Individual gridlines in the grid can be moved using the Move Gridline command. 
 •  The Options command allows all of the defining parameters of the grid to be edited numerically. 
 •  The grid can be copied from the current image and pasted onto another image using the Copy and Paste 

commands. 
 •  Finally, the grid overlay graphics can be turned on and off with the Show/Hide Grid command.  
 
Further information: 
 Define Primary Axis 
 Translate 
 Resize 
 Rotate 
 Move Gridline 
 Options 
 Show/Hide Grid 
 Copy and Paste 
 
 
Grid Define Primary Axis 
 
The Define Primary Axis command in the Grid menu is used as the first step to overlay a graphical grid over the 

current yacht sail image.  Shortcut alternatives are to press the  toolbar button or press CTRL+G.  When this 
command is selected, the user is prompted to select the end points of the primary axis of the desired grid using the 
mouse.  A graphical grid is then drawn on the screen as illustrated below: 
 

  
 



The user can select the direction in which the grid is drawn by way of noting the sequence in which primary axis end 
points are selected - the grid will be drawn to be left if the bottom end point is selected first and the grid will be drawn 
to the right if the upper end point is selected first. 
 
The user can subsequently use the other Grid tool commands to manipulate the overlay grid. 
 
Further information: 
 Translate 
 Resize 
 Rotate 
 Move Gridline 
 Options 
 Show/Hide Grid 
 Copy and Paste 
 
 
Grid Translate 
 
The grid can be moved (translated) around the screen using the Translate command in the Grid menu.   
 
The procedure for moving the grid is as follows: 
 •  From the Grid menu select Translate. 
 •  Move the mouse pointer to anywhere on the yacht sail image. 
 •  Press the left mouse button and drag the grid to the desired location by moving the mouse. 
 •  Release the left mouse button when the grid is in the desired position.  (The program then automatically exits 

from the translate mode). 
 
Further information: 
 Define Primary Axis 
 Resize 
 Rotate 
 Move Gridline 
 Options 
 Show/Hide Grid 
 Copy and Paste 
 
 
Grid Resize 
 
The Grid Resize command allows the size of the grid to be increased or decreased. 
 
The procedure for resizing the grid is as follows: 
 •  From the Grid menu select Resize. 
 •  If you wish to resize both X and Y axes at the same time move the mouse a corner of the grid, otherwise, if 

you wish to resize only the X or only the Y size of the grid move the mouse to the middle of one of the side 
edges of the grid. 

 •  Press the left mouse button and drag the grid to the new size by moving the mouse.  (It should be noted that 
opposite side or corner from the selected side or corner is maintained fixed during the resizing process). 

 •  Release the left mouse button when the grid is the desired size.  (The program then automatically exits from 
the resize mode). 

 
Further information: 
 Define Primary Axis 
 Translate 
 Rotate 
 Move Gridline 
 Options 
 Show/Hide Grid 
 Copy and Paste 
 
 



Grid Rotate 
 
The Grid Rotate command allows the orientation of the grid to be changed. 
 
The procedure for rotating the grid is as follows: 
 •  From the Grid menu select Rotate. 
 •  Move the mouse to the point on the screen you would like to be the rotation centre and click the left mouse 

button.  A    symbol will be displayed to indicate the rotation centre.  (The rotation centre can be placed 
anywhere on the screen but it probably makes more sense to put the rotation centre at the centre of the grid 
or at one of the corners.) 

 •  Move the mouse to anywhere on the screen and press the left mouse button and drag to rotate the grid. 
 •  Release the left mouse button when the grid is at the desired orientation.  (The program then automatically 

exits from the rotate mode). 
 
Further information: 
 Define Primary Axis 
 Translate 
 Resize 
 Move Gridline 
 Options 
 Show/Hide Grid 
 Copy and Paste 
 
 
Move Gridline 
 
The Move Gridline command allows the position of individual gridlines in the grid to be changed. 
 
The procedure for moving gridlines is as follows: 
 •  From the Grid menu select Move Gridline. 
 •  Move the mouse pointer over one of the gridlines. (Either direction gridlines can be selected but not the 

borders of the grid.) 
 •  Press the left mouse button and drag the gridline. 
 •  Release the left mouse button when the gridline is at the desired location.  (The program then automatically 

exits from the ‘move gridline’ mode). 
 
Further information: 
 Define Primary Axis 
 Translate 
 Resize 
 Rotate 
 Options 
 Show/Hide Grid 
 Copy and Paste 
 
 



Grid Options 
 
The Grid Options command allows all of the defining parameters of the grid to be edited numerically.  When the Grid 
Options command is selected, the following dialog box is displayed: 
 

  
 
 
The various fields and buttons in this dialog box have the following functions or meanings: 
 

Field/Button Function 
Origin x,y    The position of the origin of the grid (in image pixels) 
Orientation   The orientation (angle) of the grid in degrees 
Primary axis length    The length of the primary axis (in image pixels) 
Secondary axis length  The length of the secondary axis (in image pixels) 
Primary grid density The density of the primary grid 
Secondary grid density The density of the secondary grid 
Intersection angle The angle at which the primary and secondary axes intersect  
Orthogonal axes If ticked, the intersection angle of the grid axes will be forced to 90 degrees. 
Grid Colour The colour of the grid graphics can be changed by pressing this button 
Primary Axis lines A mini spreadsheet showing the position of the gridlines 
Secondary Axis lines A mini spreadsheet showing the position of the secondary axis gridlines. 

 
Further information: 
 Define Primary Axis 
 Translate 
 Resize 
 Rotate 
 Move Gridline 
 Show/Hide Grid 
 Copy and Paste 
 
 
Grid Show/Hide 
 
The grid overlay graphics can be hidden or shown using the Hide Grid / Show Grid command in the Grid menu.  This 
command can be used at any time.   
 
A short cut key CTRL+H can also be used but this only applies to the grid graphics when grid is the current tool. 
 
Further information: 
 Define Primary Axis 
 Translate 
 Resize 
 Rotate 
 Move Gridline 
 Options 
 Copy and Paste 
 
 



Grid Copy and Paste 
 
An overlay grid (including all of its customised parameters) can be copied from one yacht sail image file to another.  
This can allow the comparison of two yacht sail images.  
  
The procedure for copying a grid from one image to another is as follows: 
 •  Select the Yacht Sail Image you wish to copy the grid from.  (You could do this by selecting the desired file 

from the Window menu.) 
 •  Select Copy from the Grid menu. 
 •  Select the Yacht Sail Image you wish to copy the grid to.  (You could do this by selecting the desired file 

from the Window menu.) 
 •  Select Paste from the Grid menu. 
 •  It may then be necessary to realign, rotate or resize the grid to align it with the new image.  The Grid 

Translate, Rotate and Resize tools would be used for this purpose. 
 
Further information: 
 Define Primary Axis 
 Translate 
 Resize 
 Rotate 
 Move Gridline 
 Options 
 Show/Hide Grid 



Tape Measure Tool 
 
The Tape Measure Tool allows relative measurement of lengths in yacht sail images.  The tool works by the user first 
defining a reference length in the image - such as the height of the mast or the width of the transom.  The program then 
uses this reference length to calculate the scaling factor for the image.  The user is then able to measure items in the 
yacht sail image. 
 
It should be noted that because the yacht sail images processed by this program or only two dimensional, the program is 
unable to correct for perspective error in images.  The user should be aware that perspective error will affect the 
measured distance when it is not in the same plane (perpendicular to the camera axis) as the reference length.  (more 
information...) 
 
The Tape Measure Tool is used as follows: 

•  Select “Tape: Set Reference Length” from the Tools menu and define the reference length. 
•  Then select “Tape: Measure” from the Tools menu and measure an arbitrary length in the image (note that 

the result is not perspective corrected). 
 
Further information: 
 Set Reference Length 
 Show/Hide Reference 
 Measure 
 Display Previous 
 Options 
 
 
Tape: Set Reference Length 
 
The Tape: Set Reference Length command in the Tools menu initialises the tape measure tool so that measurements 
can be made in the image. 
 
The Tape Measure reference length is set as follows: 

•  Select Tape: Set Reference Length from the Tools menu (or press the  toolbar button or press 
CTRL+R). 

•  Using the mouse, select two points which define a known reference length in the image. 
•  The “Set Reference Length” dialog box (shown below reduced size) will appear from which the user should 

specify the length of the chosen reference.  The user can choose from a set of pre-defined lengths or 
manually enter the length. 

 

   
 
The user can then use the Tape Measure command to measure lengths in the image.  The user can hide the graphics 
indicating the chosen reference length by choosing Tape: Show/Hide Reference from the Tools menu. 
 
Further information: 
 Show/Hide Reference 
 Measure 
 Display Previous 
 Options 
 
 
Tape: Show/Hide Reference 
 
The tape measure reference overlay graphics can be hidden or shown using the “Tape: Hide/Show Reference Length” 
command in the Tools menu.  This command can be used at any time.   



 
A short cut key CTRL+H can also be used but this only applies to the reference length graphics when “Tape: Set 
Reference Length” was the last used tool. 
 
Further information: 
 Set Reference Length 
 Measure 
 Display Previous 
 Options 
 
 
Tape: Measure 
 
The Tape: Measure command in the Tools menu is used to make measurements in the image.  It is necessary to set a 
reference length in the image before measurements can be made. 
 
The Tape Measure Tool is used as follows: 

•  Select Tape: Measure from the Tools menu (or press the  toolbar button or press CTRL+T). 
•  Using the mouse, select two points which determine the length you wish to measure. 
•  The “Tape Measure” dialog box (shown below reduced size) will appear which shows the calculated value 

of the measured length.   
 

   
 
•  If you wish to express the measured length as a percentage of another length (e.g. stripe depth as a 

percentage of stripe length), enter the reference length in the “as percentage of” box.  The measured length 
will then be calculated as a percentage of the entered length. 

•  If you wish to assign a label to this measurement (for later use) type a name for this measurement in the 
Label box.  (See the Measurement Labels help topic for more information.) 

•  Press Close when you have finished with this dialog box. 
 
Further information: 
 Set Reference Length 
 Show/Hide Reference 
 Display Previous 
 Options 
 Measurement Labels 
 
 
Tape: Display Previous 
 
The Tape: Display Previous command from the Tools menu redisplays the previously measured length.  The tape 
measure overlay graphics are redisplayed and the results dialog box is also redisplayed (as shown below). 

 



 
 

Press the Close button to dismiss the dialog box. 
 
Further information: 
 Set Reference Length 
 Show/Hide Reference 
 Measure 
 Options 
 Measurement Labels 



Spinnaker Flying Distance Tool 
 
The Flying Distance Tool allows the estimated measurement of the flying distance of a yacht’s spinnaker from a yacht 
sail image in which the leech and luff of the spinnaker are almost coincident.  The flying distance is the straight line 
distance between points on the luff and leech of a flying spinnaker.  This function requires that: (a) a reference length be 
set in the image using the tape measure tool, (b) the locations of the luff, leech and camber point a stripe on the 
spinnaker be digitised by the user and (c) the distance around the curve be entered by the user.  The diagram below 
shows an example of the flying distance tool being used to measure spinnaker flying distance. 
 

  
 
The Flying Distance Tool is activated by selecting “Measure Flying Distance” from the Tools menu. 
 
Further information: 
 Measure Flying Distance 
 Display Previous 
 Options 
 
 
Kite: Measure Flying Distance 
 
The process to measure the flying distance of a spinnaker in an image is as follows: 

•  Firstly ensure that a reference length has been set in the image using the Tape Measure Tool (Tape: Set 
Reference Length from the Tools menu). 

•  Select Kite: Measure Flying Distance from the Tools menu (or click the  toolbar button or press 
CTRL+F) 

•  Move the mouse to the luff of the spinnaker and click the left mouse button.   
•  Move the mouse to the apex of the spinnaker and click the left mouse button. 
•  Move the mouse to the leech of the spinnaker and click the left mouse button.  (at this point the display 

would be something similar to the image shown below.) 
 

   
 
•  A dialog box will then appear (as shown below) displaying the analysis of the flying distance.  Enter the 

leech to luff distance and press Calculate.  The calculated parameters (including flying distance) will then 
be displayed.   

 



   
 
•  In some instances there will be two solutions to the calculation of flying distance - press Radius1 or 

Radius2 to select the most appropriate solution. 
•  If you wish to assign a label to this measurement (for later use) type a name for this measurement in the 

Label box.  (See the Measurement Labels help topic for more information.) 
•  Press Close to dismiss the dialog box. 
 

It should be noted that the calculated results of this tool are not perspective corrected.  This tool also makes the 
assumption that the shape of the flying spinnaker is an arc of a circle. 
 
If you wish to redisplay the results of a previous flying distance measurement, select the Display Previous command 
from the Tools menu. 
 
Further information: 
 Display Previous 
 Options 
 Measurement Labels 
 
 
Kite: Display Previous 
 
The Kite: Display Previous command from the Tools menu redisplays the results of the previous flying distance 
measurement.  The flying distance overlay graphics are redisplayed and the results dialog box is also redisplayed (as 
shown below). 

 

 
 

Press the Close button to dismiss the dialog box. 
 
Further information: 
 Measure Flying Distance 
 Options 
 Measurement Labels 



Image Measurement Labels 
 
The SailTool program allows the collation of labeled image measurements performed with the Protractor, Flying 
Distance and Tape Measure tools.  When you perform a measurement with any of these tools, a results dialog box 
appears which contains a Label edit box.  If you type a name into the Label box, the measurement will be stored for 
later use.  The measurement labels will be displayed in the results frame, will be exported into a text file when the File 
Export command is used and saved in the “.saf” file when the File Save Results command is used.



Comparison of Analysis Results 
 
The SailTool program provides an analysis tool which allows the user to perform a side-by-side comparison of analysis 
curves.  For examble, if you have two images showing mast bend, this tool allows you to display the mast bend 
parameters and the graphical curve from both images side-by-side for comparison purposes. 
 
This function is accessed as follows: 
•  From the Tools menu, select Compare Analysis Results. 
•  The “Compare Analysis Results” dialog box (shown below) is displayed: 
 

  
 
•  Select the type of Comparison you wish to perform by selecting one of the buttons on the left hand side of the dialog 

box: Mast, Leech, All Stripes in a Single Image or Same Stripe Between Images.  (NB: if there are insufficient 
files loaded into SailTool to do a particular comparison, that particular option will be greyed out). 

•  On the right hand side of the dialog box, select the files you wish to compare.  SailTool gives you a default selection 
of files which meet the Comparison Type selected in the previous step but you can select other files by clicking on 
the down arrows and selecting from the available files (with have already been loaded into SailTool). 

•  Press OK to generate and display the Graphical Comparison Window (shown below). 
 

  
 
The Comparison window shows all analysis parameters for all curves from all images selected.  A graphical 
representation of each curve is also displayed.  Each set of analysis parameters and analysis curves are colour coded for 
easy interpretation. 
 
Several features of this window can be customised by the user (display ‘%’ or ‘m’, display curves ‘relative’ or 
‘normalised, curves displayed ‘overlaid’ or ‘side-by-side’, etc).  These functions are available via the Compare: 
Options item under the Tools menu. 
 
See Also: 
 Comparison Options 
 How to display the next Stripe in the ‘Same Stripe between Images’ mode. 
 



 
Comparison Window Options 
 
Several features of the Camparison of Analysis Results window can be customised by the user as follows: 
•  From the Tools menu, select Compare: Options. 
•  The “Compare Analysis Results” dialog box (shown below) is displayed: 

 

  
 

•  Select how offset values are to be displayed in the top left hand corner.  Measurements can be displayed in % or 
metres.  Click the check box to calculate percentages relative to camber rather than as a %-age of the straight chord 
length. 

•  Select whether to overlay the graphical curves or display them side-by-side by selecting the appropriate button on the 
bottom left of the dialog. 

•  In the top-right hand box, select whether to display the curves all normalised to the same length or displayed to scale 
relative to their reference lengths (NB: Relative can only be selected if all curves have a reference length in metres). 

•  In the bottom-right-hand box, select whether to exagurate the curve offsets by clicking the ‘Scale Curve Offsets’ 
check box and entering a Scale value. 

•  Press OK once you are happy with your selections or Cancel to abort your changes. 
 
See Also: 
 Compare Analysis Results 
 How to display the next Stripe in the ‘Same Stripe between Images’ mode. 
 
 
 
Compare: Next Stripe 
 
When the Comparison Tool is used to compare the same sail stripe between different images, the program allows the 
user to select which sail stripe to compare between images.   
 
This can be done by selecting Compare: Next Stripe from the Tools  menu (in which case if you are currently 
comparing stripe number 1 between all images, selecting this option will compare stripe number 2 between all images). 
 
The stripe number to be compared between all images can also be selected from the Comparison Options dialog box 
(shown below)  
 



  
 
At the bottom right hand corner of the dialog box is the Stripe Number edit box.  Select the stripe number you wish to 
display and press OK. 
 
NB: this function is only relevant to the “Same Stripe Between Images” mode.  This feature has no meaning in the 
Mast, Leech and All Stripes in Single Image modes and hence is greyed out. 
 
See Also: 
 Compare Analysis Results 
 Comparison Options 
 



Tips 
 
A number of techniques and shortcuts help the process of sail analysis while using the SailTool program: 

•  Zoom in and out of the image using the PAGE UP and PAGE DOWN keys while selecting points to obtain 
greater accuracy of point selection. 

•  Use the keyboard shortcuts instead of the menus  
•  Use the toolbar buttons instead of the menus 
•  Enter commonly used yacht length parameters into the Yacht Class and Data fields. 
•  Be aware of the perspective correction limitations of 2D photography when performing length or angle 

measurements.  
 
•  Why are all sail analysis toolbar buttons and menus greyed out?  These toolbar buttons and menus cannot be 

used when the results frame is the current frame - Click in the sail image window to activate the toolbar 
buttons and menus. 

•  Why is ‘Select Font’ greyed out?  The Select Font command only works on the results frame text - select the 
results frame and then choose ‘Select Font’. 

 
 
Technical Limitations 
 
In order for several of the tools to be used successfully and accurately, it is necessary for the yacht sail image to be 
taken from a particular location.  If the camera isn’t located at the specified position, the analysis results could be 
erroneous.  The position requirements are as follows: 
 

Measurement Requirement 
Sail Stripe Analysis (from ON boat) The camera must be looking up at the sail from on the boat 
Sail Stripe Depth (from OFF boat) The leech and luff points must be coincident in the image. 
Spinnaker Flying Distance The leech and luff points must be coincident in the image. 
Angle Measurement The camera optical axis should be perpendicular to the plane containing 

the angle to be measured. (see Perspective Error for Angle 
Measurements below). 

Leech Twist Measurement The image must be taken such that the leech and luff of the sail are 
coincident. 

 
There are also some technical limitations inherent in using uncalibrated two-dimensional cameras.  The following text is 
offered to help the operator reduce the magnitude of any measurement errors.  Some operator judgment will be 
necessary to avoid or reduce measurement errors since it is beyond the technical capabilities of the SailTool program to 
correct for these errors automatically. 
 
Perspective Error 
 
This program processes images which are only two dimensional, hence it is not possible to correct for size differences 
due to objects being at different distances from the camera.  
 
An example of perspective error is shown below.  In the following image a camera with a fairly wide angle lens is used 
to take a photo of the yacht from behind.  Consider the situation where the mast is used as the tape measure reference 
length to measure a fictitious item of interest on the transom of the yacht.  In this situation, because the two items 
(reference and measured) are at different distances from the camera (but the program has no way of knowing it), the 
measured result will be subject to perspective error.  In this case the measured result would be approximately twice 
what the real result would be since the measured item is approximately half way between the camera and the reference 
length. 
 

                                 



 
Two ways of reducing the effect of perspective error are to: 

(a) Use a reference length which is at approximately the same distance away from the camera as the item to be 
measured, and 

(b) Photograph the yacht from a greater distance (and use a longer focal length lens) (as shown below) 
 

 
 
It should be noted that perspective error could be eliminated if the yacht was photographed using a calibrated 
stereoscopic camera and this program was modified to process stereoscopic images. 
 
Perspective Error for Angle Measurements 
 
Care should be taken when performing angle measurements that the plane defined by the angle being measured is 
perpendicular to the camera’s optical axis.  An error will result if the plane defined by the angle being measured is not 
perpendicular to the camera’s optical axis.  The amount of error will depend upon the angle at which the plane is to the 
camera’s optical axis.  This error is similar in some respects to the Perspective Error described above. 
 
Lens Distortion 
 
Some lenses (especially wide angle lenses) exhibit a lot of barrel or radial distortion.  The image below shows an 
example of barrel distortion.  The image below illustrates the photo of a rectilinear grid pattern which has been distorted 
by the camera lens.  It should be noted how the size of the square in the centre of the image is larger than the size of the 
squares around the outside of the image.  Different camera lenses will exhibit different amounts of lens distortion.  The 
image below is a fairly extreme example. 
 

  
 
With the presence of lens distortion, measurements in an image could be subject to error.  The amount and type of error 
will however depend upon where in the image measurements are taken and the amount of lens distortion present in the 
image. 
 
 
 



Technical Support 
 

 SailTool was developed by: 
 
 Centre for Marine Science & Technology 
 Curtin University of Technology 
 GPO Box U1987 
 Perth WA 6845 
 Australia 
 
 Phone: +61 8 9266 7380 
 Fax: +61 8 9266 4799 
 Email: info@cmst.curtin.edu.au 
 WWW: http://www.cmst.curtin.edu.au/ 
 
We have tried to make this help file as comprehensive as possible.  If you find something that isn’t covered by the help 
file that should be, please contact us for more information.  Similarly, if you find any errors or faults in the SailTool 
program, please let us know and we will attempt to correct it. 
 
If there are any additional features you would like to see added to SailTool, please contact us at the above address. 
 
 
 
Copyright and Intellectual Property 
 

 SailTool was developed by the Centre for Marine Science & Technology at Curtin University of Technology.  
The copyright and intellectual property contained in SailTool is vested in Curtin University.    This help document is 
©2000. 
 
The CIMAGE class is provided courtesy of Julian Smart. 
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